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TT Keys Overview

TT Keys is a custom add-on application to X_TRADER® Pro that enables the user to submit and manipulate orders using an X-keys® Desktop keypad.  The user can set the different buttons of the keypad to perform preconfigured actions. The user can also set a key to perform a keyboard macro that will send keyboard events to the machine.
Installation

1. Verify that both X_TRADER and the X_TRADER® API are installed.  Verify that X_TRADER Pro is enabled

2. Double-click on the installation file (i.e. TT_Keys_Install.exe).  This opens the TT Keys installation wizard.

3. Click the Next button through all of the screens of the installation wizard, changing the default User Information and Destination Folder if desired. 

4. The application will be installed.  The last screen will display a message that TT Keys was successfully installed. 

5. Click the Finish button.  A TT Keys shortcut icon will be added to the Desktop.  The computer does not need to be rebooted.
Product Features

TT Keys Basics
6. TT Keys can be launched by double-clicking the TT Keys desktop icon after starting X_TRADER® Pro.
7. Upon launching TT Keys, the form will be disabled while it validates that there is a valid keypad and that X_TRADER® Pro is enabled. The form will be enabled when TT Keys has downloaded all of the available fills. TT Keys will not respond to any events until the form is enabled.
8. TT Keys is composed of one simple window which will display an interface that is laid out similar to the keypad (See Figure 1).   The 20 buttons on the screen represent the buttons of the keypad.  The status label will show if the keypad is in the ON or OFF position.  This is changed by rotating the toggle switch on the side of the device.  When the red dot is displayed the device is on and active, otherwise the device is off and TT Keys will not respond to any activity on the pad.  
9. The top of the main window will display four fields; Contract, Customer, Next Qty, and Default Qty.  The Contract field will display the information for the currently loaded contract.  To load a contract drag and drop it from a window within X_TRADER.  TT Keys will display an opening message.  Once the opening message has been replaced with the contract information TT Keys is ready to send and manipulate orders. Below the contract field is a Customer combo box and two text boxes for quantities.  The user can use the customer combo box to select the customer profile to use when submitting orders.  When the TT Keys window has focus the user can use the up and down arrows on the keyboard to cycle through these values.  The quantity text boxes are used to set the default and next quantities.  The next qty will always be set to the default unless it is manually changed or the Net Pos action is performed.  After an order is placed the next qty is set back to the default qty.  When the TT Keys window has focus any numeric key press will automatically go to the next qty field and pressing the delete key will set the value to 0.
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Figure 1. TT Keys Main Window
10. The user can change the action, color, text size, and text color of a button by right clicking the button and using the context menu (See Figure 2).  The label that is displayed on the buttons can be changed by clicking the text and entering new text.
11. A TT Keys workspace can be saved to a file and then reloaded by using the Save and Open items in the File menu.  A sample workspace file, called Sample.kws, is provided in the <root>\tt\Prof Serv\TT Keys\Workspaces directory.  Note that if using the Sample.kws file you must rename it to ensure that it is not overwritten by upgrade installs in the future.  These workspace files will save all options for every button along with contract and quantity data.  By default TT Keys will store information in a file named TTKeys.kws.  If workspace information has changed TT Keys will prompt the user to save the workspace before closing the application.  TT Keys will also store format and preferences settings along with form data so that the application will be in the same state when it opens as when it was closed.
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         Figure 2. Button Context Menu
TT Keys – Menu Options 

10.  Within the File menu there are six menu items:

	· New
	Creates a new TT Keys workspace.  


	· Open…


	Opens an existing workspace.  

	· Save
	Saves current workspace.


	· Save As…
	Saves the workspace with the current/new name.


	· <Workspaces>
	A list of up to the last three used workspaces.  Selecting one will open that workspace.

	· Exit
	Exits the TT Keys application.



	
	


11. Within the Format Menu there are four menu items:

	· Font Settings…
	This will display a font dialog box to set global font settings for all buttons (Note: these settings will overwrite font size settings that were set using any button’s text size context menu).


	· Align Left
	Aligns text on left side of buttons.



	· Align Center
	Aligns text in center of buttons.



	· Align Right
	Aligns text on right side of buttons.


12. Within the Preferences Menu there are two menu items:

	· Controlled Order Color…
	This will display a color dialog box to change color that will appear next to the currently managed order in the MD TRADER® window.  The default color is yellow.



	· Set Limit Offset…
	This will display a window to set the offset from the current bid or offer in the market, in ticks, for limit orders.  This will be used for the Bid, Offer, Bid Custom Qty and Offer Custom Qty actions.  Positive values are always away from the market and negative values are always into the market.  The default value is 0.


13. Within the Help Menu there are two menu items:
	· Contents
	Displays the TT Keys ReadMe document.



	· About
	TT Keys version information.


14. When the user right-clicks on one of the buttons a context menu will appear that has the following items:
	· Button Action
	Sets the action that will be performed when the corresponding button is pressed on the keypad.



	· Button Format -> Button Color…
	This will display a color dialog box to change the color of the selected button.



	· Button Format -> Text Color
	Change the text color of the selected button to black or white.



	· Button Format -> Text Size
	Change the test size of the selected button to a point value between 8 and 12.



	· Merge…
	This will put the application in merge mode.  A window will appear asking the user to press and release keys that have been merged with a two or four button plate so that the interface matches the keypad.  Merged buttons should be pressed one at a time.  When all merged buttons have been pressed click ok to return the application to its normal state.



	· Un-Merge
	This will un-merge the selected button.


Key Actions
15. TT Keys comes with 20 predefined actions that can be assigned to any of the buttons of the keypad.  One action can be assigned to multiple keys but each key can only perform one action.  Merged keys are treated as a single key even though they use more than one button and thus can only perform one action.  The actions are listed and described below:
	Action Name
	Description

	Delete Order
	Deletes the order that is currently being controlled.

	Delete All
	Deletes all working orders for the contract that is currently in use.

	Delete Bids
	Deletes all working buy orders for the contract that is currently in use.

	Delete Offers
	Deletes all working sell orders for the contract that is currently in use.

	Buy
	Sends a market buy order with the Next Qty. 

	Sell
	Sends a market sell order with the Next Qty.

	Bid
	Sends a limit buy order using the limit offset set under the Preferences Menu with the Next Qty.  The price used to calculate the offset is determined by the price seeding hierarchy.  See Price Seeding Hierarchy section for details. (Note: this will automatically set the control to this order)

	Offer
	Sends a limit sell order using the limit offset set under the Preferences Menu with the Next Qty.  The price used to calculate the offset is determined by the price seeding hierarchy.  See Price Seeding Hierarchy section for details.  (Note: this will automatically set the control to this order)

	Buy Custom Qty
	Sends a market buy order for a quantity that is set up by the user.  When this action is set a window will appear asking for the quantity that should be associated with this action.

	Sell Custom Qty
	Sends a market sell order for a quantity that is set up by the user.  When this action is set a window will appear asking for the quantity that should be associated with this action.  

	Bid Custom Qty
	Sends a limit buy order using the limit offset under the Preferences Menu for a quantity that is set up by the user.  When this action is set a window will appear asking for the quantity that should be associated with this action.  The price used to calculate the offset is determined by the price seeding hierarchy.  See Price Seeding Hierarchy section for details. (Note: this will automatically set the control to this order)

	Offer Custom Qty
	Sends a limit sell order using the limit offset under the Preferences Menu for a quantity that is set up by the user.  When this action is set a window will appear asking for the quantity that should be associated with this action.  The price used to calculate the offset is determined by the price seeding hierarchy.  See Price Seeding Hierarchy section for details. (Note: this will automatically set the control to this order)

	Increase Price
	Changes the order that is currently being controlled by moving it up in price by one tick.

	Decrease Price
	Changes the order that is currently being controlled by moving it down in price by one tick.

	Increase  Qty
	Increments the quantity of the currently controlled order by one.

	Decrease Qty
	Decrements the quantity of the currently controlled order by one.

	Go To Market
	Changes the currently controlled order to a market order.

	Control Bid
	If control is not already set to bid then this sets the order control to the working buy order that is closest to the market.  If it is already set to bid then this will move control to the working buy that is next closest to the market.  TT Keys will set the color of the order within the MD TRADER® screen to the color chosen in the Controlled Order color menu.

	Control Offer
	If control is not already set to offer then this sets the order control to the working sell order that is closest to the market.  If it is already set to offer then this will move control to the working sell that is next closest to the market.  TT Keys will set the color of the order within the MD TRADER® screen to the color chosen in the Controlled Order color menu.

	Net Pos
	Changes the quantity to use for the next order to the current Net Position of the current contract.  Once an order is placed the TT Keys will revert back to using the default quantity.

	Switch Customer
	Selects the next customer in the Customer combo box.  Pressing this when at the last customer in the list will select the first customer. (Note: this can also be achieved by hitting the up and down arrows while the TT Keys window has focus.  The advantage of this option is that the window does not have to have focus in order to use this action.)

	Hot Key
	Sends a specific key event to the computer.  When this action is set a window will appear asking the user to perform the key event to associate with this action.

	
	


Price Seeding Hierarchy

When an offset is used to determine the order price, TT Keys will use current market data to derive the order price.  The base price used depends on what data is available and what type of order is being submitted.  The table below depicts the order in which TT Keys will seed this base price.

	Order Type
	First Attempt
	Second Attempt
	Third Attempt
	Fourth Attempt

	Sell Limit
	Current ask price
	Current bid price + 1 tick
	Last traded price
	Settle price

	Buy Limit
	Current bid price
	Current ask price – 1 tick
	Last traded price
	Settle price


If none of these prices are available then TT Keys will display an “Error – Invalid Price” status bar message telling the user that it was unable to get prices for the contract and will not send in the order.

Requirements

This application requires:

· .Net Framework 2.0

· X_TRADER® API 

· X_TRADER® Pro 
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